summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 24 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ed6f71bde1b6..6395843b13ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,42 +2,50 @@
pkgbase=python-stsci.imagestats
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
-pkgver=1.6.3
+pkgver=1.7.0
pkgrel=1
pkgdesc="STScI clipped image statistics with core functionality of IRAF's imstatistics"
arch=('i686' 'x86_64')
url="https://stsciimagestats.readthedocs.io"
license=('BSD')
-makedepends=('python-setuptools-scm' 'python-numpy')
+makedepends=('python-setuptools-scm'
+ 'python-wheel'
+ 'python-build'
+ 'python-installer'
+ 'python-numpy')
+checkdepends=('python-pytest')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('dce4aa0c76f9e00184e0f8e40ba73954')
+md5sums=('6090192128a65c961469b7b7e14e351d')
+
+get_pyver() {
+ python -c "import sys; print('$1'.join(map(str, sys.version_info[:2])))"
+}
prepare() {
- export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ sed -i -e "/oldest-supported-numpy/d" pyproject.toml
}
build() {
cd ${srcdir}/${_pyname}-${pkgver}
- python setup.py build
+ python -m build --wheel --no-isolation
}
-#check() {
-# cd ${srcdir}/${_pyname}-${pkgver}
-#
-# PYTHONPATH="build/lib.linux-${CARCH}-${_pyver}" python setup.py test
-## pytest
-#}
+check() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ PYTHONPATH="build/lib.linux-${CARCH}-cpython-$(get_pyver)" pytest || warning "Tests failed" # -vv -l -ra --color=yes -o console_output_style=count
+}
package_python-stsci.imagestats() {
- depends=('python>=3.6' 'python-numpy>=1.14' 'python-stsci.tools')
+ depends=('python>=3.7' 'python-numpy>=1.16')
+ #'python-stsci.tools')
optdepends=('python-stsci.imagestats-doc: Documentation for STScI Imagestats')
cd ${srcdir}/${_pyname}-${pkgver}
install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE.txt
install -D -m644 -t "${pkgdir}/usr/share/doc/${pkgname}" README.rst
- python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
-# export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
-# rm "${pkgdir}/usr/lib/python${_pyver}/site-packages/stsci/__init__.py"
-# rm "${pkgdir}/usr/lib/python${_pyver}/site-packages/stsci/__pycache__"/*
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}