summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6395843b13ba..1c75869ec245 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=python-stsci.imagestats
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
-pkgver=1.7.0
+pkgver=1.8.0
pkgrel=1
pkgdesc="STScI clipped image statistics with core functionality of IRAF's imstatistics"
arch=('i686' 'x86_64')
@@ -15,18 +15,12 @@ makedepends=('python-setuptools-scm'
'python-numpy')
checkdepends=('python-pytest')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('6090192128a65c961469b7b7e14e351d')
+md5sums=('aee640c7526cb4516a6699b60a154cb2')
get_pyver() {
python -c "import sys; print('$1'.join(map(str, sys.version_info[:2])))"
}
-prepare() {
- cd ${srcdir}/${_pyname}-${pkgver}
-
- sed -i -e "/oldest-supported-numpy/d" pyproject.toml
-}
-
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -36,11 +30,11 @@ build() {
check() {
cd ${srcdir}/${_pyname}-${pkgver}
- PYTHONPATH="build/lib.linux-${CARCH}-cpython-$(get_pyver)" pytest || warning "Tests failed" # -vv -l -ra --color=yes -o console_output_style=count
+ PYTHONPATH="build/lib.linux-${CARCH}-cpython-$(get_pyver)" pytest "build/lib.linux-${CARCH}-cpython-$(get_pyver)" || warning "Tests failed" # -vv -l -ra --color=yes -o console_output_style=count
}
package_python-stsci.imagestats() {
- depends=('python>=3.7' 'python-numpy>=1.16')
+ depends=('python>=3.9' 'python-numpy>=1.22')
#'python-stsci.tools')
optdepends=('python-stsci.imagestats-doc: Documentation for STScI Imagestats')
cd ${srcdir}/${_pyname}-${pkgver}