summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ffaa8482b369..17a4e7496c77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,8 @@
# Contributor: Florian Wittmann
pkgname=python-subprocrunner
-_name="${pkgname#python-}"
-pkgver=1.6.0
-pkgrel=2
+pkgver=2.0.0
+pkgrel=1
pkgdesc='Python wrapper library for subprocess module'
arch=('any')
url='https://github.com/thombashi/subprocrunner'
@@ -13,14 +12,15 @@ license=('MIT')
depends=('python-mbstrdecoder')
makedepends=('python-setuptools')
# checkdepends=('python-pytest-runner' 'python-pytest-mock' 'python-typepy')
-source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
- "$pkgname-$pkgver.tar.gz.asc::https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz.asc")
-sha256sums=('1c1e928db282e7453853744290908d04047a8fb3b49ff1e7f8284e6a3be3a810'
+source=(
+ "$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/s/subprocrunner/subprocrunner-$pkgver.tar.gz"
+ "$pkgname-$pkgver.tar.gz.asc::https://files.pythonhosted.org/packages/source/s/subprocrunner/subprocrunner-$pkgver.tar.gz.asc")
+sha256sums=('fd22aad8befd610461536463955e205122fed80303b814cc926c3a4a8d9aaf3c'
'SKIP')
validpgpkeys=('BCF9203E5E80B5607EAE6FDD98CDA9A5F0BFC367')
build() {
- cd "$_name-$pkgver"
+ cd "subprocrunner-$pkgver"
python setup.py build
}
@@ -32,7 +32,7 @@ build() {
package() {
export PYTHONHASHSEED=0
- cd "$_name-$pkgver"
+ cd "subprocrunner-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
install -Dm644 README.rst -t "$pkgdir/usr/share/doc/$pkgname"
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"