summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 13 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 92f6b27962c7..b68919e58b43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,25 @@
-# Contributor: Vladimir Gorbunov <truedaemon@gmail.com>
+# Maintainer: Vladimir Gorbunov <truedaemon@gmail.com>
pkgbase=python-svglib
-pkgname=('python2-svglib' 'python-svglib')
+pkgname=('python-svglib')
_name=svglib
-pkgver=0.8.1
-pkgrel=2
+pkgver=1.0.0
+pkgrel=1
pkgdesc="A pure-Python library for reading and converting SVG files."
arch=('any')
url="http://pypi.python.org/pypi/svglib/$pkgver"
license=('LGPL')
options=(!emptydirs)
-makedepends=('python-setuptools' 'python2-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
- "xrange.patch")
-sha256sums=('1f8cb633f154b83987e3a906a55cf69c8739c0df5ea4eee024677c3e8fb62f55'
- '21d9f9634ba0c92ee6b21c720978a3825ff92974177cab17e72015c62ec10a47')
-
-prepare() {
- cd "$srcdir/svglib-$pkgver"
- # Fix python 3 compatibility
- patch -Np1 -i "${srcdir}/xrange.patch"
-}
-
-package_python2-svglib() {
- cd "$srcdir/svglib-$pkgver"
- depends=('python2' 'python2-reportlab' 'python2-lxml')
- python2 setup.py install --root="$pkgdir/" --optimize=1
- mv "${pkgdir}/usr/bin/svg2pdf" "${pkgdir}/usr/bin/svg2pdf-py2"
-}
+depends=('python'
+ 'python-lxml'
+ 'python-cssselect2'
+ 'python-tinycss2'
+ 'python-reportlab')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('b17d4a6352f6c25ca3718d2b66a2f1ecfcdf558b1f6646c37f5c191b655979f1')
package_python-svglib() {
- cd "$srcdir/svglib-$pkgver"
- depends=('python' 'python-reportlab' 'python-lxml')
+ cd "${srcdir}/${_name}-${pkgver}"
python setup.py install --root="$pkgdir/" --optimize=1
}