summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1e04ef5f4280..a619e04ddf03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: txtsd <aur.archlinux@ihavea.quest>
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
pkgname=python-syncedlyrics
_pkgname=syncedlyrics
-pkgver=0.4.0
-pkgrel=2
+pkgver=0.5.0
+pkgrel=1
pkgdesc='Get an LRC format (synchronized) lyrics for your music'
arch=('any')
url='https://github.com/rtcq/syncedlyrics'
@@ -12,9 +13,10 @@ depends=('python>=3.7' 'python-requests>=2.28.1' 'python-rapidfuzz>=2.13.2'
'python-beautifulsoup4>=4.11.1')
makedepends=('python-build' 'python-installer' 'python-wheel'
'python-poetry-core')
+checkdepends=('python-pytest')
conflicts=("${pkgname}-git")
source=("${_pkgname}-${pkgver}".tar.gz::"https://github.com/rtcq/${_pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('13672adb05ec6f51c3dafe6efb34b7379c3477f47ffaf9d87d9c1dbf70900956')
+sha256sums=('82d4315d753875c8e483dfad95e9c13bc5136fbd62e06bda6ce7b33b18c1fe26')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
@@ -23,7 +25,7 @@ build() {
check() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- python -m unittest -v
+ pytest tests.py
}
package() {