summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b7e1e58b3dbf..96acc038310e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=python-tabledata
pkgver=1.3.0
-pkgrel=3
+pkgrel=4
pkgdesc='Python library to represent tabular data'
arch=('any')
url='https://github.com/thombashi/tabledata'
@@ -14,7 +14,7 @@ makedepends=(
'git'
'python-setuptools'
'python-build'
- 'python-install'
+ 'python-installer'
'python-wheel'
'python-sphinx'
'python-sphinx_rtd_theme')
@@ -25,7 +25,7 @@ validpgpkeys=('BCF9203E5E80B5607EAE6FDD98CDA9A5F0BFC367')
build() {
cd "$pkgname"
- python -m build --wheel --skip-dependency-check --no-isolation
+ python -m build --wheel --no-isolation
cd docs
PYTHONPATH=../ make man
}
@@ -38,7 +38,7 @@ check() {
package() {
export PYTHONHASHSEED=0
cd "$pkgname"
- python -m install --optimize=1 --destdir="$pkgdir/" dist/*.whl
+ python -m installer --destdir="$pkgdir/" dist/*.whl
install -Dm644 README.rst -t "$pkgdir/usr/share/doc/$pkgname"
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
install -Dm644 docs/_build/man/tabledata.1 -t "$pkgdir/usr/share/man/man1/"