summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 22 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 91dd3ba8623b..2fb453a3e0dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,30 @@
-pkgname='python-tabledata'
-_module='tabledata'
-pkgver='0.0.5'
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Contributor: Florian Wittmann
+
+_pkgname=tabledata
+pkgname=python-${_pkgname}
+pkgver=1.1.2
pkgrel=1
-pkgdesc="A Python library to represent tabular data for pytablewriter/pytablereader/SimpleSQLite."
-url="https://github.com/thombashi/tabledata"
-depends=('python' 'python-pathvalidate>=0.16.2' 'python-dataproperty>=0.29.1' 'python-logbook>=1.1.0' 'python-six' 'python-typepy>=0.0.20' 'python-wheel')
-makedepends=('python-setuptools')
-license=('MIT')
+pkgdesc='Represent tabular data'
arch=('any')
-source=("https://github.com/thombashi/tabledata/archive/v${pkgver}.tar.gz")
-md5sums=('7b6256da07b2381c50cb8db8df1241f9')
+url='https://github.com/thombashi/tabledata'
+license=('MIT')
+depends=('python-dataproperty' 'python-typepy')
+makedepends=('python-setuptools')
+provides=("${_pkgname}")
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('db893596ab9066e5c4f002ae0fed70657e3b75cceb52dd1de5a0e145e338d830')
build() {
- cd "${srcdir}/${_module}-${pkgver}"
- python setup.py build
+ cd "${_pkgname}-${pkgver}"
+ python setup.py build
}
package() {
- cd "${srcdir}/${_module}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ cd "${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 'README.rst' "${pkgdir}/usr/share/doc/${_pkgname}/README.rst"
+ install -Dm644 'LICENSE' "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
}
+
+# vim: ts=2 sw=2 et: