summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 17 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f68e2154b096..5f5ca1a8fd66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,28 @@
# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
# Contributor: Florian Wittmann
-_pkgname=tcconfig
-pkgname=python-${_pkgname}
+_pkgname='tcconfig'
+pkgname="python-${_pkgname}"
pkgver=0.26.0
-pkgrel=1
+pkgrel=2
pkgdesc='tc command wrapper'
arch=('any')
url='https://github.com/thombashi/tcconfig'
+_url_pypi='https://pypi.org/project/tcconfig'
license=('MIT')
depends=('python-dataproperty'
- 'python-docker'
- 'python-humanreadable'
- 'python-loguru'
- 'python-msgfy'
- 'python-path'
- 'python-pyparsing'
- 'python-pyroute2'
- 'python-simplesqlite'
- 'python-subprocrunner'
- 'python-typepy'
- 'python-voluptuous')
+ 'python-docker'
+ 'python-humanreadable'
+ 'python-loguru'
+ 'python-msgfy'
+ 'python-path'
+ 'python-pyparsing'
+ 'python-pyroute2'
+ 'python-simplesqlite'
+ 'python-subprocrunner'
+ 'python-typepy'
+ 'python-voluptuous')
makedepends=('python-setuptools')
-provides=("${_pkgname}")
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
sha256sums=('b4b064f96c28f7a171552e2854c04849585fd47aba6df46539a0de776a4eebbc')
@@ -34,8 +34,8 @@ build() {
package() {
cd "${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm644 'README.rst' "${pkgdir}/usr/share/doc/${_pkgname}/README.rst"
- install -Dm644 'LICENSE' "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -Dvm644 'README.rst' -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dvm644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
# vim: ts=2 sw=2 et: