summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 142b123209e8..cf56f5026e6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,15 @@
_name=Telethon
pkgname=python-telethon
-pkgver=1.10.10
-pkgrel=3
+pkgver=1.11.0
+pkgrel=1
pkgdesc="Full-featured Telegram client library for Python 3"
arch=(any)
url="https://github.com/LonamiWebs/Telethon"
license=(MIT)
depends=('python-pyaes' 'python-rsa')
makedepends=('python-setuptools')
-
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('126b392db57b83526e18779b7c6f4011789c2dd02377f64004afd0e0ce29a37e')
+sha256sums=('9d13512038f62b0fba266a510b500e57d4cfe8013ce9a7b613725ab7de96321a')
build() {
cd "$srcdir/$_name-$pkgver"
@@ -21,6 +20,9 @@ package() {
cd "$srcdir/$_name-$pkgver"
python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-}
+ # make sure we don't install annoying files
+ local _site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ rm -rf "$pkgdir/$_site_packages/tests/"
+}