summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 152f1f835da7..ccca671c0581 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_name=Telethon
pkgname=python-telethon
-pkgver=1.17.0
+pkgver=1.17.1
pkgrel=1
pkgdesc="Full-featured Telegram client library for Python 3"
arch=(any)
@@ -8,16 +8,16 @@ url="https://github.com/LonamiWebs/Telethon"
license=('MIT')
depends=('python-pyaes' 'python-rsa')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.17.0.tar.gz")
-sha256sums=('dd38dd46dfd023cfdf9158f0b730c181ebff89a3b78408e7301552b543b62b92')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.17.1.tar.gz")
+sha256sums=('2d5f29ee0f0ea835ecc81407b8cd540760cbaabdead177f2891fff06eb234ff0')
build() {
- cd "$srcdir/Telethon-1.17.0"
+ cd "$srcdir/Telethon-1.17.1"
python3 setup.py build
}
package() {
- cd "$srcdir/Telethon-1.17.0"
+ cd "$srcdir/Telethon-1.17.1"
python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"