summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 64ad3cfa394d..da7f30d5db9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_name=Telethon
pkgname=python-telethon
-pkgver=1.17.5
+pkgver=1.18.2
pkgrel=1
pkgdesc="Full-featured Telegram client library for Python 3"
arch=(any)
@@ -8,18 +8,23 @@ url="https://github.com/LonamiWebs/Telethon"
license=('MIT')
depends=('python-pyaes' 'python-rsa')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.17.5.tar.gz")
-sha256sums=('958432bb3849d3e1fecfb45e211832a579fb4340a1d2b21b0d1a7d30407e39ec')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.18.2.tar.gz")
+sha256sums=('4695ff737692f745c2e44f1f22996b415ce7715d7e764e27b0528fb61d30cefb')
build() {
- cd "$srcdir/Telethon-1.17.5"
+ cd "$srcdir/Telethon-1.18.2"
python3 setup.py build
}
package() {
- cd "$srcdir/Telethon-1.17.5"
+ cd "$srcdir/Telethon-1.18.2"
python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
+ # make sure we don't install any world-writable or root-readable-only files
+ # we shouldn't need to fix ownership as we extract tarballs as a non-root user
+ # https://github.com/pypa/setuptools/issues/1328
+ # https://github.com/LonamiWebs/Telethon/issues/1605
+ chmod u=rwX,go=rX -R "$pkgdir"
# make sure we don't install annoying files
local _site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
rm -rf "$pkgdir/$_site_packages/tests/"