summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e098caa01a1..c7a84b983a9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_name=Telethon
pkgname=python-telethon
-pkgver=1.24.0
+pkgver=1.25.0
pkgrel=1
pkgdesc="Full-featured Telegram client library for Python 3"
arch=(any)
@@ -8,16 +8,16 @@ url="https://github.com/LonamiWebs/Telethon"
license=('MIT')
depends=('python-pyaes' 'python-rsa')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.24.0.tar.gz")
-sha256sums=('818cb61281ed3f75ba4da9b68cb69486bed9474d2db4e0aa16e482053117452c')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.25.0.tar.gz")
+sha256sums=('676d97b926e6d30dbed31d6c6e6611cdec9fc82759785cea55c4770b74614290')
build() {
- cd "$srcdir/Telethon-1.24.0"
+ cd "$srcdir/Telethon-1.25.0"
python3 setup.py build
}
package() {
- cd "$srcdir/Telethon-1.24.0"
+ cd "$srcdir/Telethon-1.25.0"
python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
# make sure we don't install any world-writable or root-readable-only files