summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3849da393bf9..c8980dc3230b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_name=Telethon
pkgname=python-telethon
-pkgver=1.14.0
+pkgver=1.15.0
pkgrel=1
pkgdesc="Full-featured Telegram client library for Python 3"
arch=(any)
@@ -8,16 +8,16 @@ url="https://github.com/LonamiWebs/Telethon"
license=('MIT')
depends=('python-pyaes' 'python-rsa')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.14.0.tar.gz")
-sha256sums=('d8bb37f80c4a8befa92d0525f00a578a74064645e48d7aa0cc4731f3d813e1b9')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.15.0.tar.gz")
+sha256sums=('3f4c1496353365100baf932736e537def0cff4eaf67b85944fb329b87c4be361')
build() {
- cd "$srcdir/Telethon-1.14.0"
+ cd "$srcdir/Telethon-1.15.0"
python3 setup.py build
}
package() {
- cd "$srcdir/Telethon-1.14.0"
+ cd "$srcdir/Telethon-1.15.0"
python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"