summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6d1d745618f3..13efdc47de39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_name=Telethon
pkgname=python-telethon
-pkgver=1.20
+pkgver=1.21
pkgrel=1
pkgdesc="Full-featured Telegram client library for Python 3"
arch=(any)
@@ -8,16 +8,16 @@ url="https://github.com/LonamiWebs/Telethon"
license=('MIT')
depends=('python-pyaes' 'python-rsa')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.20.tar.gz")
-sha256sums=('41fea16755897c91a2d1a90b4c6d178dad06746650230c3adf5d7fb2e285f1d3')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.21.tar.gz")
+sha256sums=('8ce569183ea0824133c263b6ea3ae98224608fd319a2ada4f98387e31a3ee51a')
build() {
- cd "$srcdir/Telethon-1.20"
+ cd "$srcdir/Telethon-1.21"
python3 setup.py build
}
package() {
- cd "$srcdir/Telethon-1.20"
+ cd "$srcdir/Telethon-1.21"
python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
# make sure we don't install any world-writable or root-readable-only files