summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 06a853facb98..5a3c9ae08d53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor:
pkgname=python-tensorflow-probability
pkgver=0.9.0
-pkgrel=1
+pkgrel=2
pkgdesc="Probabilistic reasoning and statistical analysis in TensorFlow"
url="https://github.com/tensorflow/probability"
arch=('any')
@@ -13,6 +13,9 @@ source=("https://github.com/tensorflow/probability/archive/v${pkgver}.tar.gz")
sha256sums=('2c58d592e93bb8733110a819cb8f06ede91faa1b12c01342e406f1387dc7d919')
build() {
+ # Force OpenJDK-11
+ export JAVA_HOME=/usr/lib/jvm/java-11-openjdk
+
cd "${srcdir}"/probability-${pkgver}
bazel build --copt=-O3 --copt=-march=native :pip_pkg
cd ./bazel-bin/pip_pkg.runfiles/tensorflow_probability