summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 49cbbb3154b9..e46b80b93221 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Oystein Sture <oysstu (at) gmail (dot) com>
-# Contributor:
+# Contributor:
pkgname=python-tensorflow-probability
pkgver=0.23.0
-pkgrel=2
+pkgrel=3
pkgdesc="Probabilistic reasoning and statistical analysis in TensorFlow"
url="https://github.com/tensorflow/probability"
arch=('any')
@@ -11,18 +11,18 @@ depends=('python' 'python-tensorflow' 'python-numpy' 'python-six' 'python-decora
makedepends=('python-setuptools' 'bazel')
source=("https://github.com/tensorflow/probability/archive/v${pkgver}.tar.gz")
sha256sums=('a00769550da9284acbd69e32a005507153ad39b0c190feca2bbbf6373366cc14')
-
+
build() {
# Force OpenJDK-11
export JAVA_HOME=/usr/lib/jvm/java-11-openjdk
cd "${srcdir}"/probability-${pkgver}
bazel build --copt=-O3 --copt=-march=native :pip_pkg
- cd ./bazel-bin/pip_pkg.runfiles/tensorflow_probability
+ cd ./bazel-bin/pip_pkg.runfiles/_main
python setup.py build --release
}
package() {
- cd "${srcdir}"/probability-${pkgver}/bazel-bin/pip_pkg.runfiles/tensorflow_probability
+ cd "${srcdir}"/probability-${pkgver}/bazel-bin/pip_pkg.runfiles/_main
python setup.py install --release --root=${pkgdir} --optimize=1 --skip-build
}