summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c8e72bf6806e..4ee1824d6234 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
-# Maintainer: PumpkinCheshire <sollyonzou at gmail dot com>
+# Maintainer: PumpkinCheshire <me at pumpkincheshire dot top>
pkgname=python-termplotlib
_name=termplotlib
-pkgver=0.3.5
+pkgver=0.3.7
pkgrel=1
pkgdesc="Plotting on the command line"
arch=('any')
url="https://github.com/nschloe/termplotlib"
license=('GPL')
-makedepends=('python'
- 'python-setuptools')
+depends=('python' 'python-numpy' 'gnuplot')
+makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('d99d6620a945ed377a4d54c34855c816b54de0e7ba5d6816c2a620abdef46b6d')
+b2sums=('409b2c0eabb3a476fdf0e3641722a6786daabc7f7270fcf7703e5b7c62ce5230d8591ca348e49d5accaee74ff388042a79b52155cf7710a8c5b29e01a7247456')
build() {
cd "$srcdir/$_name-$pkgver"
+ export PYTHONHASHSEED=0
python -c "from setuptools import setup; setup()" build
}