summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cb9d8dc70414..b4067ff089f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
_base=textual
pkgname=python-${_base}
pkgver=0.38.1
-pkgrel=2
+pkgrel=3
pkgdesc="Modern Text User Interface framework"
arch=(any)
url="https://github.com/Textualize/${_base}"
license=(MIT)
-depends=(python-rich python-importlib-metadata python-typing_extensions python-tree-sitter)
+depends=(python-rich python-importlib-metadata python-typing_extensions python-tree-sitter-languages)
makedepends=(python-build python-installer python-poetry-core)
checkdepends=(python-pytest-asyncio python-pytest-aiohttp python-time-machine)
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
@@ -26,7 +26,6 @@ check() {
test-env/bin/python -m pytest \
--ignore=tests/test_markdown.py \
--ignore=tests/test_markdownviewer.py \
- --ignore=tests/text_area/test_languages.py \
--ignore=tests/snapshot_tests/test_snapshots.py \
-k 'not textual_env_var'
}