summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 101c1c38f7c2..92299ebe36b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ url="https://github.com/Textualize/${_base}"
license=(MIT)
depends=(python-rich python-importlib-metadata python-typing_extensions)
makedepends=(python-build python-installer python-poetry-core)
-checkdepends=(python-pytest python-exceptiongroup python-aiohttp python-msgpack python-jinja python-syrupy python-click python-time-machine)
+# checkdepends=(python-pytest python-exceptiongroup python-aiohttp python-msgpack python-jinja python-syrupy python-click python-time-machine)
# python-pytest-aiohttp python-pytest-asyncio
optdepends=('python-aiohttp: for HTTP server'
'python-click: for click event as mouse button'
@@ -24,17 +24,17 @@ build() {
python -m build --wheel --skip-dependency-check --no-isolation
}
-check() {
- cd ${_base}-${pkgver}
- python -m venv --system-site-packages test-env
- test-env/bin/python -m installer dist/*.whl
- test-env/bin/python -m pytest \
- --ignore=tests/snapshot_tests/test_snapshots.py \
- --ignore=tests/test_widget.py \
- --ignore=tests/devtools/test_devtools.py \
- --ignore=tests/devtools/test_redirect_output.py \
- --ignore=tests/devtools/test_devtools_client.py
-}
+# check() {
+# cd ${_base}-${pkgver}
+# python -m venv --system-site-packages test-env
+# test-env/bin/python -m installer dist/*.whl
+# test-env/bin/python -m pytest \
+# --ignore=tests/snapshot_tests/test_snapshots.py \
+# --ignore=tests/test_widget.py \
+# --ignore=tests/devtools/test_devtools.py \
+# --ignore=tests/devtools/test_redirect_output.py \
+# --ignore=tests/devtools/test_devtools_client.py
+# }
package() {
cd ${_base}-${pkgver}