summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD78
1 files changed, 38 insertions, 40 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2118382c6933..ba72eb9214e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,49 @@
-# Maintainer: DanManN <dnahimov@gmail.com>
-# Python package author: Matthew Honnibal <matt@explosion.ai>
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+# Contributor: DanManN <dnahimov@gmail.com>
+
pkgname=python-thinc-git
-_origpkgname=thinc
-pkgver=6.12.1.r2400.a6badde8
-pkgrel=3
+pkgver=8.0.0rc0.r0.g36e20cee
+pkgrel=1
pkgdesc="Practical Machine Learning for NLP"
-arch=("x86_64")
+arch=(i686 x86_64 armv7h aarch64)
url="https://github.com/explosion/thinc"
-license=("MIT")
-depends=('cython'
- 'python-numpy'
- 'python-murmurhash'
- 'python-cymem'
- 'python-preshed'
- 'python-wrapt'
- 'python-plac'
- 'python-tqdm'
- 'python-six'
- 'python-dill'
- 'python-hypothesis'
- 'python-pytest'
- 'python-mock'
- 'python-blis'
- 'python-msgpack-numpy'
- 'python-msgpack'
- 'python-cytoolz'
- )
-
-makedepends=('git' 'python-setuptools')
-optdepends=('python-spacy: examples')
-provides=('python-thinc')
-conflicts=('python-thinc')
-source=("git+https://github.com/explosion/$_origpkgname.git")
+license=(MIT)
+depends=(
+ python-blis
+ python-catalogue
+ python-cymem
+ python-hypothesis
+ python-mock
+ python-murmurhash
+ python-numpy
+ python-pathlib
+ python-plac
+ python-preshed
+ python-pydantic
+ python-six
+ python-srsly
+ python-tqdm
+ python-wasabi
+)
+makedepends=(git python-setuptools cython)
+provides=(python-thinc)
+conflicts=(python-thinc)
+source=("git+https://github.com/explosion/thinc.git")
md5sums=('SKIP')
-prepare() {
- cd "$_origpkgname"
- git checkout $(curl https://api.github.com/repos/explosion/$_origpkgname/releases | grep tag_name | cut -d '"' -f4 | head -n 1)
-}
pkgver() {
- cd "$_origpkgname"
- printf "%s.r%s.%s" "$(cat thinc/about.py | grep -i version | grep -v '#' | cut -d "'" -f2 | head -n 1)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd thinc
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd thinc
+ python setup.py build
}
package() {
- cd "$_origpkgname"
- python setup.py install --root="${pkgdir}/" --optimize=1
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd thinc
+ python setup.py install --skip-build --root="${pkgdir}" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
}