summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4abfbe32b132..5c2e9d85feeb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,18 @@
_name=tiledb
pkgname=python-$_name
-pkgver=0.17.1
-pkgrel=2
+pkgver=0.17.3
+pkgrel=1
pkgdesc='Pythonic interface to the TileDB array storage manager'
arch=(x86_64)
url="https://github.com/TileDB-Inc/TileDB-Py"
license=(MIT)
_pyminor=10
-depends=("python>=3.$_pyminor" "python<3.$((_pyminor + 1))" 'python-numpy>=1.21' python-packaging)
-makedepends=(python-setuptools python-build python-installer python-wheel)
+# TODO: make it use system libmagic (file) and capnproto
+depends=(capnproto aws-sdk-cpp spdlog "python>=3.$_pyminor" "python<3.$((_pyminor + 1))" 'python-numpy>=1.21' python-packaging)
+makedepends=(git cmake pybind11 python-setuptools python-build python-installer python-wheel)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('b6749c5785a5e4a407356633ecaf447d2dcae46f0320a693a280d525dbd61fdd')
+sha256sums=('c934118162cfc4ab9967435f857fa724023b5b16d7a66e5fcc0d99cc46ed3662')
build() {
cd "$_name-$pkgver"