summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ba0e6897c154..75e679ce3d81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,11 +5,11 @@ pkgname=python-todo-t
pkgver=0
pkgrel=1
pkgdesc="Command-line todo list manager"
-url="https://github.com/sjl/t"
+url="https://github.com/sjl/t.git"
makedepends=('git' 'python')
license=('GPL')
arch=('any')
-source=("git://github.com/sjl/t")
+source=("git+https://github.com/sjl/t.git")
provides=('python-todo-t')
md5sums=('SKIP')
@@ -18,7 +18,12 @@ sha256sums=('SKIP')
pkgver() {
cd "t"
-
- # Get the version number.
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf '0.r%s.%s' \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+
+package() {
+ cd "t"
+ python setup.py install --root=$pkgdir
+}
+