summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a75e325a5065..5963b1e0f5d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,26 @@
pkgname=python-torchaudio
_pkgname=audio
-pkgver=0.10.1
+pkgver=0.11.0
pkgrel=1
pkgdesc="Data manipulation and transformation for audio signal processing, powered by PyTorch"
arch=('any')
url="https://github.com/pytorch/audio"
license=('BSD')
-depends=('python' 'sox' 'python-pytorch')
+depends=('python' 'python-pytorch')
optdepends=('python-kaldi-io')
makedepends=('git' 'python-setuptools' 'cmake' 'ninja')
conflicts=('python-torchaudio-git')
source=("git+$url#tag=v${pkgver}")
sha512sums=('SKIP')
+prepare() {
+ cd "$srcdir/${_pkgname}"
+ # Use sourceforge url to fetch zlib
+ # See https://github.com/pytorch/audio/pull/2297
+ git cherry-pick -n e92a17c35fdff6b0622b0791b43e665c5d05c4b4
+}
+
build() {
cd "$srcdir/${_pkgname}"
CUDA_HOME=/opt/cuda/ BUILD_SOX=1 python setup.py build