summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a1c4b7b1ce73..1314395829e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,17 +9,17 @@ arch=(any)
url="https://github.com/bfueldner/tr064"
license=(MIT)
depends=(python-requests python-lxml)
-makedepends=(git python-pip)
+makedepends=(git python-pytest-runner python-wheel)
source=(git+"https://github.com/bfueldner/tr064#commit=6b12f879fa5ccec4cd2d68fac48db1c2815f131c")
b2sums=("SKIP")
build() {
cd $_name
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd $_name
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}