summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6a55942b28ac..8ad1cfa1e4ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,34 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
-pkgname=('python-traittypes')
+pkgname='python-traittypes'
_module='traittypes'
-pkgver='0.0.6'
-pkgrel=1
+pkgver='0.2.1'
+pkgrel=3
pkgdesc="Traitlet types for NumPy, SciPy and friends."
url="https://github.com/jupyter-widgets/traittypes"
depends=('python'
'python-traitlets'
'python-numpy'
'python-pandas')
-checkdepends=('python-pytest')
-makedepends=('python-setuptools')
+checkdepends=('python-pytest' 'python-xarray')
+makedepends=('git' 'python-setuptools')
license=('BSD')
arch=('any')
-source=("https://github.com/jupyter-widgets/traittypes/archive/${pkgver}.tar.gz")
-sha256sums=('8b2a8a68ef83aa8dc11a0e3b91f83cb3b9709089db85e3ca49aec990f644748c')
+source=("git+https://github.com/jupyter-widgets/traittypes.git#commit=af2ebeec9e58b73a12d4cf841bd506d6eadb8868")
+sha256sums=('SKIP')
build() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${_module}"
python setup.py build
}
package() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${_module}"
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}
check() {
- cd "${srcdir}/${_module}-${pkgver}"
- python -m unittest
+ cd "${_module}"
+ sed -i -e "s/np.int/int/" traittypes/tests/test_traittypes.py
+ PYTHONPATH=. pytest
}