summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f56cf24e22a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Omar Pakker <archlinux@opakker.nl>
+
+_pkgname=transip-api
+pkgname=python-${_pkgname}
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="Python implementation of TransIP's API (unofficial)"
+arch=('any')
+url="https://github.com/benkonrath/transip-api"
+license=('MIT')
+makedepends=('git' 'python-setuptools')
+depends=('python-rsa' 'python-requests' 'python-suds-jurko')
+source=("https://github.com/benkonrath/${_pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('b1d50e62f61fdeadd94cdbf4288b6ebb')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ python3 setup.py build
+}
+
+check() {
+ cd "${_pkgname}-${pkgver}"
+ python3 setup.py test
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ python3 setup.py install --root="${pkgdir}" --optimize=1
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}