summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..24a3e9fcdbd1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: GI_Jack <iamjacksemail@hackermail.com>
+
+pkgbase=python-travispy
+pkgname=('python-travispy' 'python2-travispy')
+_pypiname=travispy
+pkgver=0.3.5
+pkgrel=1
+pkgdesc="TravisPy is a Python API for Travis CI. It follows the official API and is implemented as similar as possible to Ruby implementation."
+url="https://github.com/menegazzo/travispy"
+arch=('any')
+license=('GPLv3')
+depends=('python-coverage' 'python-pytest' 'python-pytest-rerunfailures' 'python-requests')
+source=(${_pypiname}-${pkgver}.tar.gz::"https://github.com/menegazzo/travispy/archive/v${pkgver}.tar.gz")
+sha256sums=('85293ac89d2cea0244c2a9cb64e447096993ac53fa41cc3ab8ae18d6a4d575b0')
+
+package_python-travispy() {
+ depends=('python-coverage' 'python-pytest' 'python-pytest-rerunfailures' 'python-requests')
+
+ cd ${_pypiname}-${pkgver}
+ python setup.py install -O1 --root="${pkgdir}" --prefix=/usr
+}
+
+package_python2-travispy() {
+ depends=('python2-coverage' 'python2-pytest' 'python2-pytest-rerunfailures' 'python2-requests')
+
+ cd ${_pypiname}-${pkgver}
+ python2 setup.py install -O1 --root="${pkgdir}" --prefix=/usr
+}
+
+