summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aa0694656e7d..e7460becd48c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,24 @@
_pyname=uharfbuzz
pkgname=python-$_pyname
pkgver=0.16.1
-pkgrel=1
+pkgrel=2
pkgdesc='Streamlined Cython bindings for the harfbuzz shaping engine'
-arch=('x86_64')
+arch=(x86_64)
url="https://github.com/harfbuzz/$_project"
-license=('Apache')
-depends=('python')
-makedepends=('cython' 'python-setuptools' 'python-scikit-build')
+license=(Apache)
+depends=(python)
+makedepends=(cython
+ python-setuptools-scm
+ python-scikit-build)
source=("https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_pyname-$pkgver.zip")
sha256sums=('509aee6075c9c68fba250281b0a1d2cbf3c26a865af567589dead5e80cffe6af')
build() {
- cd "$_pyname-$pkgver"
- python setup.py build
+ cd "$_pyname-$pkgver"
+ python setup.py build
}
package() {
- cd "$_pyname-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd "$_pyname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}