summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd6d2d088a1d..618a954e0360 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,8 @@
# Contributor: Robert Kubosz <kubosz.robert@gmail.com>
_base=uqbar
pkgname=python-${_base}
-pkgver=0.6.9
+_pkgver=7.0.0
+pkgver=0.7.0
pkgrel=1
pkgdesc="Tools for building documentation with Sphinx, Graphviz and LaTeX"
arch=(any)
@@ -12,29 +13,29 @@ license=(MIT)
depends=(python-sphinx python-unidecode python-black)
makedepends=(python-build python-installer python-setuptools python-wheel)
checkdepends=(python-pytest-cov graphviz)
-source=(${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
-sha512sums=('bd992f9578bbf0411b0129a0646bbcf521104323737781e082e06d33bd3305a867cf3015e8710b139053cdcd3097f4ae42481e2a8abec753d9c740016ad2ee20')
+source=(${pkgname}-${_pkgver}.tar.gz::${url}/archive/v${_pkgver}.tar.gz)
+sha512sums=('a63e9d6c805e77d98b2dd971b89d6d63f1dd80c4ce67a7df418246614348c5f9fa7361eb10acb983ca05357c51c637a4dd384b3789cbeddad3d8bf85ae9439aa')
prepare() {
- cd ${_base}-${pkgver}
+ cd ${_base}-${_pkgver}
sed -i '/sphinx_immaterial/d' docs/source/conf.py
}
build() {
- cd ${_base}-${pkgver}
+ cd ${_base}-${_pkgver}
python -m build --wheel --skip-dependency-check --no-isolation
PYTHONPATH="$PWD" make -C docs man
}
check() {
- cd ${_base}-${pkgver}
+ cd ${_base}-${_pkgver}
python -m venv --system-site-packages test-env
test-env/bin/python -m installer dist/*.whl
- test-env/bin/python -m pytest tests -k 'not find_executable and not sphinx_book_text_broken_strict'
+ test-env/bin/python -m pytest tests -k 'not find_executable'
}
package() {
- cd ${_base}-${pkgver}
+ cd ${_base}-${_pkgver}
PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm644 "docs/build/man/${_base}.1" -t "${pkgdir}/usr/share/man/man1/"
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"