summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2bc5ed4e063a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Kazuo Teramoto <kaz.rag at gmail dot com>
+
+pkgname=python-urwidtrees-git
+pkgver=1.0.2.r35.9142c59
+pkgrel=1
+pkgdesc="Tree widgets for urwid"
+arch=("any")
+url="https://github.com/pazz/urwidtrees"
+license=("GPL")
+depends=("python-urwid>=1.1.0" "python-mock")
+makedepends=("git" "python-sphinx")
+provides=('python-urwidtrees')
+conflicts=('python-urwidtrees')
+source=("git+https://github.com/pazz/urwidtrees.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd urwidtrees
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd urwidtrees
+ python setup.py build
+}
+
+package() {
+ cd urwidtrees
+ python setup.py install --root="${pkgdir}" --skip-build
+}