summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 16 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 55050320fa4e..64f6c749d07a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,25 @@
-# Maintainer: Dean Galvin <deangalvin3@gmail.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Dean Galvin <deangalvin3@gmail.com>
-_pkgname="vincenty"
-pkgname="python-vincenty"
-pkgdesc="Calculate the geographical distance (in kilometers or miles) between 2 points with extreme accuracy."
+pkgname=python-vincenty
+_pkg="${pkgname#python-}"
pkgver=0.1.4
-pkgrel=1
+pkgrel=2
+pkgdesc="Calculates geographical distance between 2 points with extreme accuracy"
url="https://github.com/maurycyp/vincenty"
license=('Unlicense')
arch=('any')
-makedepends=('python-setuptools')
-depends=('python>=3.4')
-conflicts=('python-vincenty')
-source=("https://pypi.python.org/packages/source/v/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+depends=('python')
+makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/v/$_pkg/$_pkg-$pkgver.tar.gz")
sha256sums=('eaa2f2de835f369cbd71c1a01ccd4e0d412da0f4aeef7c9692242b9ce182785a')
-package() {
- cd ${srcdir}/${_pkgname}-${pkgver}
+build() {
+ cd "$_pkg-$pkgver"
+ python -m build --wheel --no-isolation
+}
- python3 setup.py install --root="$pkgdir" --prefix=/usr --optimize=1
+package() {
+ cd "$_pkg-$pkgver"
+ PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
}