summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5795b0c42575..4f829a066f29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: pumpkincheshire <sollyonzou@gmail.com>
+# Maintainer: PumpkinCheshire <me at pumpkincheshire dot top>
pkgname=python-viztracer
_name=viztracer
-pkgver=0.13.0
+pkgver=0.13.4
pkgrel=1
pkgdesc='VizTracer is a low-overhead logging/debugging/profiling tool that can trace and visualize your python code execution.'
arch=('x86_64')
@@ -14,10 +14,11 @@ optdepends=('python-rich: Full function support'
'python-orjson: Full function support'
'chromium: browser to open html results')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('1eb76bc74e0a11d494666bda3253618cdfeffbd42959d7f730b5e62025ca0c2a')
+b2sums=('944723e1e6a7f85249fd99c9d013b5d3899103ff80b191b2c926aba8c2769ba2d1c9bb9e0dbd82ea387e4351389d5f706fac4424be171dfc69ae9fa71fc243d3')
build() {
cd "$_name-$pkgver"
+ export PYTHONHASHSEED=0
python setup.py build
}