summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 18 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b44b68f50374..c751e48e576b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=python-vt-py
-pkgver=0.14.0
+_pkg="${pkgname#python-}"
+pkgver=0.15.0
pkgrel=1
pkgdesc="Official Python client library for VirusTotal's REST API"
arch=('any')
@@ -9,33 +10,35 @@ url="https://github.com/virustotal/vt-py"
license=('Apache')
depends=('python-aiohttp')
makedepends=(
- 'python-pytest-runner'
- 'python-setuptools'
'python-build'
'python-installer'
- 'python-wheel'
- 'python-sphinx')
-checkdepends=('python-pytest-httpserver' 'python-pytest-asyncio')
+ 'python-setuptools'
+ 'python-sphinx'
+ 'python-wheel')
+checkdepends=('python-pytest' 'python-pytest-asyncio' 'python-pytest-httpserver')
provides=('python-virustotal')
replaces=('python-virustotal-api')
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('5dc86b9fa80f26d9949fa5f25712e2923ce347c63c8da7e50724392f33109628')
+sha256sums=('0a84bf5b62b80c140c2f26e9cdafa1bbe0bde73decff610f4d908c1ba1e79975')
+
+prepare() {
+ cd "$_pkg-$pkgver"
+ sed -i '/setup_requires/d' setup.py
+}
build() {
- cd "vt-py-$pkgver"
+ cd "$_pkg-$pkgver"
python -m build --wheel --no-isolation
- cd docs
- PYTHONPATH=../ sphinx-build -b man source _build
+ PYTHONPATH="$PWD" sphinx-build -b man docs/source _build
}
check() {
- cd "vt-py-$pkgver"
+ cd "$_pkg-$pkgver"
pytest -x --disable-warnings
}
package() {
- export PYTHONHASHSEED=0
- cd "vt-py-$pkgver"
- python -m installer --destdir="$pkgdir/" dist/*.whl
- install -Dm644 docs/_build/vt-py.1 -t "$pkgdir/usr/share/man/man1/"
+ cd "$_pkg-$pkgver"
+ PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
+ install -Dm644 "_build/$_pkg.1" -t "$pkgdir/usr/share/man/man1/"
}