summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a69c1a2003c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: DanManN <dnahimov@gmail.com>
+# Python package author: Ines Montani <ines@explosion.ai>
+pkgname=python-wasabi-git
+_origpkgname=wasabi
+pkgver=0.0.10.r72.0363236
+pkgrel=1
+pkgdesc="A lightweight console printing and formatting toolkit"
+arch=("x86_64")
+url="https://github.com/ines/wasabi"
+license=("MIT")
+depends=('python')
+makedepends=("python-setuptools")
+provides=('python-wasabi')
+conflicts=('python-wasabi')
+source=("git+https://github.com/ines/$_origpkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_origpkgname"
+ printf "%s.r%s.%s" "$(cat wasabi/about.py | grep -i version | grep -v '#' | cut -d '"' -f2 | head -n 1)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$_origpkgname"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}