summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 21 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cfd37c54d585..7b70c91416b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Brenden Davidson <davidson.brenden15@gmail.com>
-pkgname="python-webpy"
-pkgver="0.51"
-pkgrel=1
+pkgname=python-webpy
+pkgver=0.51
+pkgrel=2
pkgdesc="A web framework for Python"
arch=("any")
url="https://webpy.org/"
@@ -10,14 +10,24 @@ license=('custom')
_name=${pkgname#python-}
depends=(
- "python"
+ "python-cheroot>=6.0.0"
+)
+
+checkdepends=(
+ "python-pytest>=4.6.2"
+
+ # Omitted to disable DB tests
+ # "python-dbutils"
+ # "python-pymysql>=0.9.3"
+ # "python-mysql-connector>=8.0.19"
+ # "python-psycopg2>=2.8.4"
)
source=(
"$pkgname-$pkgver.tar.gz::https://github.com/webpy/webpy/archive/$pkgver.tar.gz"
)
sha256sums=(
- "550ed5fb18c7626c578cc2119fd45a9a898b7815fc81a4ac85ae2ed383a0ec5f"
+ "550ed5fb18c7626c578cc2119fd45a9a898b7815fc81a4ac85ae2ed383a0ec5f"
)
build() {
@@ -25,6 +35,12 @@ build() {
/usr/bin/python setup.py build
}
+# DB tests have been purposefully disabled by removing their dependencies.
+check() {
+ cd "$_name-$pkgver"
+ py.test tests $*
+}
+
package() {
cd "$_name-$pkgver"
/usr/bin/python setup.py install --root="$pkgdir" --optimize=1 --skip-build