summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD73
1 files changed, 43 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 25fab758795c..dc624311cdf5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,57 @@
-# Maintainer: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
+# Maintainer: Pellegrino Prevete (tallero) <pellegrinoprevete@gmail.com>
+# Contributor: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
# Contributor: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
# Contributor: Maurizio Porrato <maurizio.porrato@gmail.com>
-_realname=wokkel
-pkgbase=python-wokkel-git
-pkgname=('python-wokkel-git' 'python2-wokkel-git')
+_py=python
+_pkg=wokkel
+_pkgname="${_py}-${_pkg}"
+pkgbase="${_pkgname}-git"
+pkgname=(
+ "${pkgbase}"
+)
pkgver=0.7.1.r45.g9df5060
pkgrel=1
pkgdesc="Twisted Jabber support library - git version"
-license=('custom:"Wokkel License"')
-url="http://wokkel.ik.nu/"
-source=("git+https://github.com/ralphm/wokkel")
+license=(
+ 'custom:"Wokkel License"'
+)
+url="http://${_pkg}.ik.nu/"
+_ns="ralphm"
+_url="https://github.com/${_ns}/${_pkg}"
arch=(any)
-makedepends=('git' 'python-setuptools' 'python2-setuptools')
+makedepends=(
+ 'git'
+ "${_py}-setuptools"
+)
+_branch="remove-py2-compat"
+source=("${_pkgname}::git+${_url}#branch=${_branch}")
+md5sums=('SKIP')
pkgver() {
- cd "$srcdir/$_realname"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "${_pkgname}"
+ git describe --long --tags \
+ | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package_python-wokkel-git() {
- depends=('python-twisted')
- conflicts=('python-wokkel' 'python-wokkel-hg')
- replaces=('python-wokkel-hg')
- provides=('python-wokkel=0.8')
-
- cd "$srcdir/$_realname"
- python setup.py install --root="$pkgdir/" --optimize=1
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-}
-
-package_python2-wokkel-git() {
- depends=('python2-twisted')
- conflicts=('python2-wokkel' 'python2-wokkel-hg')
- replaces=('python2-wokkel-hg')
- provides=('python2-wokkel=0.8')
-
- cd "$srcdir/$_realname"
- python2 setup.py install --root="$pkgdir/" --optimize=1
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ depends=(
+ "${_py}-twisted"
+ )
+ replaces=(
+ "${_pkgname}-hg"
+ )
+ provides=(
+ "${_pkgname}=0.8")
+ conflicts=(
+ "${_pkgname}"
+ "${_pkgname}-hg"
+ )
+
+ cd "${_pkgname}"
+ "${_py}" setup.py install --root="$pkgdir/" \
+ --optimize=1
+ install -Dm644 LICENSE \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-md5sums=('SKIP')