summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2682560df7cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+
+pkgname=python-x2go
+pkgver=0.6.1.3
+pkgrel=2
+pkgdesc="Python module providing X2Go client API"
+url="http://www.x2go.org/"
+arch=('any')
+license=('AGPL')
+makedepends=('python-setuptools')
+depends=('python-gevent' 'python-paramiko' 'python-requests'
+ 'python-simplejson' 'python-xlib' 'nxproxy')
+source=("http://code.x2go.org/releases/source/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('08b951b434ba3b0e232fc5d01ab07c4b1d9c0e8d16af9722f78f52dd271a09f8')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+}
+