summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f2b47eaf57b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Chris Warrick <aur@chriswarrick.com>
+pkgname=python-yapsy
+_pyname=Yapsy
+pkgver=1.10.423
+pkgrel=1
+pkgdesc='Yet Another Plugin SYstem'
+arch=('any')
+url='http://yapsy.sourceforge.net/'
+license=('BSD')
+depends=('python')
+makedepends=('python-setuptools')
+options=(!emptydirs)
+source=("http://pypi.python.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
+md5sums=('fb0e0afbfc1e6086e7d34e093cf3f294')
+
+package() {
+ cd "${srcdir}/${_pyname}-${pkgver}"
+ python3 setup.py install --root="${pkgdir}/" --optimize=1
+ install -D -m644 src3/package/LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: