summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6cd38ad4fbbb..0954ba520776 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=('python-zstandard')
_pkgname='zstandard'
pkgver='0.10.2'
-pkgrel=1
+pkgrel=2
pkgdesc="Python bindings to the Zstandard (zstd) compression library"
url="https://github.com/indygreg/python-zstandard"
depends=('python')
@@ -12,8 +12,15 @@ checkdepends=('python-hypothesis')
optdepends=('python-cffi')
license=('BSD')
arch=('x86_64')
-source=("https://github.com/indygreg/python-zstandard/archive/$pkgver.tar.gz")
-sha256sums=('f684c1457f99c344f9bb5268cca49cd96fcf239b7d27acf3785390427a6d1476')
+source=("https://github.com/indygreg/python-zstandard/archive/$pkgver.tar.gz"
+ "hypothesis-4.patch")
+sha256sums=('f684c1457f99c344f9bb5268cca49cd96fcf239b7d27acf3785390427a6d1476'
+ 'e639bc7774c2ccfb145240858bd8f99af5bbadec38fe7071aea5159f18d13504')
+
+prepare() {
+ cd "${srcdir}"
+ patch -p0 < hypothesis-4.patch
+}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"