summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 14 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4aed1ae0424a..a7d3141fdf98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,27 @@
-# Maintainer: Elena ``of Valhalla'' Grandi <elena.valhalla@gmail.com>
+# Maintainer: Carsten Feuls <archlinux@carstenfeuls.de>
+
pkgname=python2-caldav
-pkgver=0.4.0
-pkgrel=2
+pkgver=0.5.0
+pkgrel=1
pkgdesc="a caldav client library"
arch=('any')
-url="https://bitbucket.org/cyrilrbt/caldav/wiki/Home"
+url="https://pypi.python.org/pypi/caldav"
license=('GPL')
depends=('python2' 'python2-lxml' 'python2-vobject' 'python2-dateutil' 'python2-distribute' 'python2-six' 'python2-requests')
-backup=()
-conflicts=()
options=(!emptydirs)
-install=
-source=(http://pypi.python.org/packages/source/c/caldav/caldav-${pkgver}.tar.gz)
+source=("git+https://github.com/python-caldav/caldav.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/caldav"
+ # relase 0.5.0 commit
+ git checkout 38c1a4cad6fd3d361cdd7a99905d279727099225
+}
package() {
- cd "$srcdir/caldav-$pkgver"
+ cd "$srcdir/caldav"
python2 setup.py install --root="$pkgdir/" --optimize=1
rm -r "$pkgdir/usr/lib/python2.7/site-packages/tests"
}
# vim:set ts=2 sw=2 et:
-md5sums=('0ebae509fb16e1ee7c113639c1567645')
-sha1sums=('c94d749f22767162693bb8523acd45f6f3c83a1b')
-sha256sums=('1e512f2989901d853ba43a3e98b1daff77569663ac3a7e29492fcecf4e86f858')