summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 385d723e498a..529ee86eb290 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Caesim404 <caesim404 at gmail dot com>
-
+
pkgname=python2-cfscrape
_pypiname=${pkgname/python2-/}
-pkgver=1.9.2
+pkgver=1.9.3
pkgrel=1
pkgdesc="A simple Python module to bypass Cloudflare's anti-bot page, using Requests"
arch=(any)
@@ -10,16 +10,12 @@ url="https://github.com/Anorov/cloudflare-scrape"
license=(MIT)
depends=(python2-requests python2-pyexecjs nodejs)
makedepends=(python2-setuptools)
-source=("https://files.pythonhosted.org/packages/source/${_pypiname::1}/${_pypiname}/${_pypiname}-${pkgver}.tar.gz"
- "https://raw.githubusercontent.com/Anorov/cloudflare-scrape/master/LICENSE")
-sha256sums=('a10883f9424c7edd27f419209acca9d5af461fbf93e3cb7dfe7188722d3c8d52'
- '0dee0611b80471ef37e44bd2e7bcbc59e19251b2f24bf9753cefed002830787a')
+source=("https://files.pythonhosted.org/packages/source/${_pypiname::1}/${_pypiname}/${_pypiname}-${pkgver}.tar.gz")
+sha256sums=('7ff269d2e88ba8fa97994275b4d58c722c84d39f579624becc89111e72265c64')
+
package() {
- cd "${srcdir}"
+ cd "${srcdir}/${_pypiname}-${pkgver}"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-
- cd "${_pypiname}-${pkgver}"
-
python2 setup.py install --root="$pkgdir" --optimize=1
}