summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..266951b9654d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=python2-coloredlogs
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Colored stream handler for the logging module"
+arch=('any')
+depends=('python2' 'python2-humanfriendly')
+makedepends=('python2-setuptools')
+url="https://github.com/xolox/python-coloredlogs"
+license=('MIT')
+options=(!emptydirs)
+source=(https://pypi.python.org/packages/source/c/${pkgname#python2-}/${pkgname#python2-}-$pkgver.tar.gz)
+md5sums=('0808f29e09eb26443ce833fdace0d543')
+sha256sums=('11067ca91532ba4a316fa53b005152a08b3e015dcb1234d393cfc25af88ebc3e')
+provides=('ansi2html' 'python2-coloredlogs')
+conflicts=('ansi2html')
+
+build() {
+ cd "$srcdir/${pkgname#python2-}-$pkgver"
+
+ msg 'Building...'
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname#python2-}-$pkgver"
+
+ msg 'Installing...'
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}