summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 62bbad8318c4..2de2c8468eb4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Timothée Ravier <tim@siosm.fr>
pkgname=(python2-dulwich python-dulwich)
-pkgver=0.18.3
+pkgver=0.18.5
pkgrel=1
pkgdesc='Pure-Python implementation of the Git file formats and protocols'
arch=('any')
@@ -9,13 +9,11 @@ url='https://www.dulwich.io/'
license=('GPL2')
depends=()
options=(!emptydirs)
-source=("https://www.dulwich.io/releases/dulwich-${pkgver}.tar.gz"{,.asc})
-validpgpkeys=('DC837EE14A7E37347E87061700806F2BD729A457') # Jelmer Vernooij
-sha256sums=('d34c2628f89a5ac632fa462b2edd5afcfbf512793cfa14452d4c52f786962a8a'
- 'SKIP')
+source=("https://github.com/jelmer/dulwich/archive/upstream/${pkgver}.tar.gz")
+
build() {
- cd "dulwich-${pkgver}"
+ cd "dulwich-upstream-${pkgver}"
python2 setup.py build
python setup.py build
}
@@ -23,15 +21,17 @@ build() {
package_python-dulwich() {
depends=('python')
conflicts=('python2-dulwich')
- cd "dulwich-${pkgver}"
+ cd "dulwich-upstream-${pkgver}"
python setup.py install --root="$pkgdir/" --skip-build --optimize=1
}
package_python2-dulwich() {
depends=('python2')
conflicts=('python-dulwich')
- cd "dulwich-${pkgver}"
+ cd "dulwich-upstream-${pkgver}"
python2 setup.py install --root="$pkgdir/" --skip-build --optimize=1
}
# vim:set ts=2 sw=2 et:
+
+md5sums=('96e7a12f745c1f00c2923cac8e1efa0d')