summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 25 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3670e6db1e68..f9dcf216af7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,43 @@
# Maintainer: Cedric Girard <girard.cedric@gmail.com>
-pkgname='python2-flask-restplus'
-pkgver='0.10.1'
-pkgrel='1'
+_pythonmod=flask-restplus
+pkgname=('python2-flask-restplus' 'python-flask-restplus')
+pkgbase='python2-flask-restplus'
+pkgver=0.10.1
+pkgrel=1
pkgdesc='custom actions for flask to help manage your application'
arch=('any')
url='http://pypi.python.org/pypi/Flask-Restplus/'
license=('BSD')
-depends=('python2-flask>=0.8' 'python2-six>=1.3.0' 'python2-jsonschema' 'python2-pytz' 'python2-aniso8601>=0.82')
-checkdepends=('python2-blinker' 'python2-rednose' 'python2-nose' 'python2-mock' 'python2-tzlocal')
-makedepends=('python2-setuptools')
source=("https://pypi.io/packages/source/f/flask-restplus/flask-restplus-${pkgver}.tar.gz")
sha1sums=('d6162efccd7e7c794f435252adcf78a262cfa969')
-build() {
- cd "flask-restplus-${pkgver}"
- python2 ./setup.py build
-}
-
-check() {
- cd "flask-restplus-${pkgver}"
+check_python2-flask-restplus() {
+ checkdepends=('python2-blinker' 'python2-rednose' 'python2-nose' 'python2-mock' 'python2-tzlocal')
+ cd ${srcdir}/${_pythonmod}-$pkgver
python2 ./setup.py test
}
-package() {
- cd "flask-restplus-${pkgver}"
+package_python2-flask-restplus() {
+ depends=('python2-flask>=0.8' 'python2-six>=1.3.0' 'python2-jsonschema' 'python2-pytz' 'python2-aniso8601>=0.82')
+ cd ${srcdir}/${_pythonmod}-$pkgver
python2 ./setup.py install --root="${pkgdir}" --prefix="/usr"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"
}
+check_python-flask-restplus() {
+ checkdepends=('python-blinker' 'python-rednose' 'python-nose' 'python-mock' 'python-tzlocal')
+ cd ${srcdir}/${_pythonmod}-$pkgver
+ python ./setup.py test
+}
+
+package_python-flask-restplus() {
+ depends=('python-flask>=0.8' 'python-six>=1.3.0' 'python-jsonschema' 'python-pytz' 'python-aniso8601>=0.82')
+ cd ${srcdir}/${_pythonmod}-$pkgver
+ python ./setup.py install --root="${pkgdir}" --prefix="/usr"
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+
# vim:set ts=2 sw=2 et: