summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 18 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8c6b21f838d1..7f53e5dba951 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,21 +4,33 @@
pkgname=python2-gevent-socketio
pkgver=0.3.6
-pkgrel=2
+pkgrel=3
pkgdesc="SocketIO server based on the gevent pywsgi server, a Python network library."
arch=(any)
url="http://pypi.python.org/pypi/gevent-socketio"
license=(BSD)
depends=(python2 python2-gevent python2-gevent-websocket)
makedepends=(python2-setuptools)
-source=("https://pypi.python.org/packages/source/g/gevent-socketio/gevent-socketio-${pkgver}.tar.gz")
-md5sums=(33f745d74885366a07da516c000854b6)
+source=(
+ "https://pypi.python.org/packages/source/g/gevent-socketio/gevent-socketio-${pkgver}.tar.gz"
+ 'gevent-110-no-int-header.patch'
+)
+md5sums=(
+ 33f745d74885366a07da516c000854b6
+ 87a9efb9d61ebca90810901d708ae9e2
+)
package () {
-
cd "${srcdir}/gevent-socketio-${pkgver}"
- python2 setup.py install --root="${pkgdir}/" --optimize=1
- install -Dm0644 "${srcdir}/gevent-socketio-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ # Workaround for https://github.com/abourget/gevent-socketio/issues/223
+ # as reported by Alan Beale.
+ #
+ # References:
+ # https://github.com/abourget/gevent-socketio/pull/221
+ # https://github.com/abourget/gevent-socketio/pull/237
+ patch -p1 -i ../gevent-110-no-int-header.patch
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm0644 "${srcdir}/gevent-socketio-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}