summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 22 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aa81e4d184b9..524fe983a141 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,41 @@
-# Contributor: Atlanis <emallson@archlinux.us>
-_pkgname=python2-gmusicapi
+# Contributor: Jonathan Arnold <jdarnold@archlinux.us>
+# Formerly: Atlanis <emallson@archlinux.us>
+_projectname=gmusicapi
+_pkgname=python2-${_projectname}
pkgname=$_pkgname-git
-pkgver=20140310
-pkgrel=2
+pkgver=VERSION
+pkgrel=3
pkgdesc="Allows control of Google Music with Python"
arch=('any')
-url="https://github.com/simon-weber/Unofficial-Google-Music-API"
+url="https://github.com/simon-weber/gmusicapi"
license=('BSD')
groups=()
depends=('python2' 'python2-validictory' 'python2-decorator' 'mutagen' 'python2-protobuf' 'python2-requests' 'python2-dateutil' 'python2-proboscis' 'python2-oauth2client' 'python2-mock' 'python2-appdirs' 'python2-six' 'python2-httplib2>=0.8' 'python2-gflags')
makedepends=('python2-setuptools' 'git')
optdepends=()
-provides=('python2-gmusicapi')
-conflicts=('python2-gmusicapi')
+provides=($_pkgname)
+conflicts=($_pkgname)
replaces=()
backup=()
options=(!emptydirs)
install=
changelog=
noextract=()
-_gitroot="https://github.com/simon-weber/Unofficial-Google-Music-API.git"
-_gitname="$_pkgname"
+source=("$_projectname::git+https://github.com/simon-weber/gmusicapi.git")
+md5sums=('SKIP')
-package() {
- cd "$srcdir"
- msg "Connecting to GIT server...."
+pkgver() {
+ cd "$srcdir/${_projectname}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
- if [ -d $_gitname ] ; then
- cd $_gitname && git pull origin
- msg "The local files are updated."
- else
- git clone $_gitroot $_gitname
- fi
+build() {
+ cd "$srcdir/${_projectname}"
- msg "GIT checkout done or server timeout"
- msg "Starting make..."
+}
- rm -rf "$srcdir/$_gitname-build"
- git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
- cd "$srcdir/$_gitname-build"
- python2 setup.py install --root="$pkgdir" --optimize=1
+package() {
+ cd "$srcdir/${_projectname}"
+ python2 setup.py install --root="$pkgdir" --optimize=1
}
+