summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b73a1e1f7d12
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: M0Rf30
+
+pkgname=python2-gnupg-isis
+name=python-gnupg
+pkgver=2.0.1
+pkgrel=1
+pkgdesc='A modified version of python-gnupg, including security patches, extensive documentation, and extra features. The gnupg module allows Python programs to make use of the functionality provided by the GNU Privacy Guard.'
+url='https://github.com/isislovecruft/python-gnupg'
+license=('GPL3')
+arch=('any')
+depends=('python2' 'gnupg' 'python2-psutil')
+conflicts=('python2-gnupg')
+provides=('python2-gnupg')
+source=("https://github.com/isislovecruft/python-gnupg/archive/$pkgver.tar.gz")
+
+build() {
+ cd $name-$pkgver
+ python2 setup.py build
+}
+
+package() {
+ cd $name-$pkgver
+ python2 setup.py install --root=${pkgdir} --optimize=1
+}
+md5sums=('492126fac43aa3fe86c4e7c70440b6ac')