summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eacc98b7b2a5..b9716e76b5a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,21 @@
# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgname=python2-humanfriendly
-pkgver=4.12.1
+pkgver=4.16.1
pkgrel=1
pkgdesc='Human-friendly output for text interfaces using Python'
arch=(any)
-url='https://humanfriendly.readthedocs.io'
+url=https://humanfriendly.readthedocs.io
license=(MIT)
-depends=(python2 python2-monotonic)
+depends=(python2)
makedepends=(python2-setuptools)
options=(!emptydirs)
-source=(https://files.pythonhosted.org/packages/8a/17/2f49d6b94908ff21031f2daaac498170e64983ddcc34d8d1becd2c45b03b/humanfriendly-$pkgver.tar.gz)
-sha256sums=(937b4d2c99d29007023ebcab23579429541bfb3357a97e5df38fc5d851a112a3)
-sha512sums=(cca8c14b63a7113a06e5f99b5d28ba4228705bfe9b25873f74ac711116fc1b71debd021284573d9cfd41906c825fbf914b779b785359bc9d617f388e5cb633db)
+source=(https://pypi.io/packages/source/h/humanfriendly/humanfriendly-$pkgver.tar.gz)
+sha256sums=(ed1e98ae056b597f15b41bddcc32b9f21e6ab4f3445f9faad1668675de759f7b)
+sha512sums=(c69efd4fb4c56811d7cd81fde0ca367d32db062a5d2ebb22316d2c69f4d6244500d2456680d66a5cb3a72b8d50c640756e92b87ac98d50cbee0d9411e1738bab)
package() {
- cd $srcdir/humanfriendly-$pkgver
- python2 setup.py install --root=$pkgdir --optimize=1
+ cd humanfriendly-$pkgver
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -Dm 644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}