summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 13 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 84b94b762af7..c6647fa2e860 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer : jyantis <yantis@yantis.net>
+# Maintainer : Yen Chi Hsuan <yan12125@gmail.com>
+# Contributor: jyantis <yantis@yantis.net>
# Contributor: Rob McCathie <archaur at rmcc dot com dot au>
# Contributor: Yanus Poluektovich <ypoluektovich@gmail.com>
# Contributor: Kyle Keen <keenerd@gmail.com>
@@ -8,31 +9,20 @@
pkgname=python2-imaging
pkgver=1.1.7
-pkgrel=10
+pkgrel=11
pkgdesc="PIL. Provides image processing capabilities for python"
arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'armv6l')
url="http://www.pythonware.com/products/pil/index.htm"
license=('custom:"pil"')
-depends=('python2' 'libjpeg' 'freetype2' 'lcms')
-makedepends=('tk' 'sane' 'patch')
+depends=('python2' 'libjpeg' 'freetype2' 'lcms')
+makedepends=('tk' 'sane')
optdepends=('tk: for the ImageTK module'
'sane: for the ImageSane module')
-provides=("pil=${pkgver}" "python-imaging=${pkgver}" 'python2-pillow=1.0')
-conflicts=('pil' 'python-imaging')
-replaces=('pil' 'python-imaging')
-source=(
- http://effbot.org/downloads/Imaging-${pkgver}.tar.gz
- patch_freetype_includes.patch
- )
-md5sums=('fc14a54e1ce02a0225be8854bfba478e'
- 'd0fdf5b560fb010dde8a9c40f1f84e9c')
-
-prepare() {
- pwd
- # Package "freetype2" has its includes in a directory with the same name,
- # but these sources want it in "freetype". This patch fixes it.
- patch "Imaging-${pkgver}/_imagingft.c" patch_freetype_includes.patch
-}
+provides=("pil=${pkgver}" 'python2-pillow=1.0')
+conflicts=('pil')
+replaces=('pil')
+source=(http://effbot.org/downloads/Imaging-${pkgver}.tar.gz)
+md5sums=('fc14a54e1ce02a0225be8854bfba478e')
build() {
cd "${srcdir}/Imaging-${pkgver}"
@@ -48,13 +38,13 @@ build() {
package() {
cd "${srcdir}/Imaging-${pkgver}"
python2 setup.py install --root="${pkgdir}" --optimize=1
-
+
pushd Sane
python2 setup.py install --root="${pkgdir}" --optimize=1
popd
-
+
install -dm755 "${pkgdir}/usr/include/python2.7/"
- install -m644 -t "${pkgdir}/usr/include/python2.7/" libImaging/*.h
+ install -m644 -t "${pkgdir}/usr/include/python2.7/" libImaging/*.h
# do not have files ending in .py in /usr/bin
for f in pildriver pilprint pilconvert pilfile pilfont; do