summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 95596cbc9c44..24651cbc824a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,23 @@
pkgname=python2-isort
pkgver=4.3.21
-pkgrel=1
+pkgverfix=-2
+pkgrel=2
pkgdesc="A Python utility / library to sort Python imports."
arch=('any')
url="https://github.com/timothycrosley/isort"
license=('MIT')
depends=('python2-futures' 'python2-setuptools')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/timothycrosley/isort/archive/$pkgver.tar.gz")
-sha512sums=('a393956a997687996b025c2a37c655efebdd988c52f6d6914db79613a5e0febbf92b0c6007c6db07af079db78e4c235cad0578089b565cb474cdfbbac9031e6d')
+source=("$pkgname-$pkgver$pkgverfix.tar.gz::https://github.com/timothycrosley/isort/archive/$pkgver$pkgverfix.tar.gz")
+sha512sums=('fc2aa00c87196864864d2516b8be7acdedcf40d71d1931510e4b878dbd2b6da0b579661b50221f03f4aa5560c8bf23d5e1e10a2694d2b741ca09a92e40a4c687')
build() {
- cd isort-$pkgver
+ cd isort-$pkgver$pkgverfix
python2 setup.py build
}
package() {
- cd isort-$pkgver
+ cd isort-$pkgver$pkgverfix
python2 setup.py install --root="$pkgdir" --optimize=1
install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE